New Campaign Creation Service Disruption

Incident Report for Findem

Resolved

The issue has been resolved. Thank you for your patience while we worked to restore service.
Posted Jun 30, 2025 - 11:28 PDT

Monitoring

A fix has been implemented and we’re monitoring the results to ensure the issue is fully resolved.
Posted Jun 30, 2025 - 11:09 PDT

Identified

The issue has been identified, and we’re working on a fix. We’ll share updates as progress is made.
Posted Jun 30, 2025 - 08:53 PDT

Investigating

We’re currently investigating a potential issue with campaigns not saving and will provide updates as soon as more information is available.
Posted Jun 30, 2025 - 08:51 PDT
This incident affected: Findem Web Application (Campaigns).