iCIMS ATS Operational Issues

Incident Report for Findem

Resolved

This incident has been resolved.
Posted Mar 24, 2026 - 11:20 PDT

Investigating

We are currently experiencing intermittent failures when syncing data to iCIMS. Our team has identified this as a connectivity issue with iCIMS APIs that is affecting multiple customers.
We are actively working to resolve this as quickly as possible and will provide an update once the issue is settled.
Posted Mar 19, 2026 - 16:01 PDT
This incident affected: Integrations (ATS - iCIMS).